www.gt4dc.co.uk
Maintain, Modify and DRIVE your GT-Four


It is currently Sun Jun 16, 2024 1:23 am




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: avc-r not working
PostPosted: Sat Feb 03, 2024 2:01 pm 
Offline
Clubman

Joined: Mon Jan 04, 2010 9:07 pm
Posts: 65
Car Model: None
Hi my avc-r boost controller has stopped working for some reason
It powers up fine, but no display/readings?

any thoughts on this, is there a way to bench test it to get the display running to rule out
any other problems, any advise welcome


Top
 Profile  
 
 Post subject: Re: avc-r not working
PostPosted: Sun Feb 11, 2024 9:47 pm 
Offline
Clubman

Joined: Mon Jan 04, 2010 9:07 pm
Posts: 65
Car Model: None
any thoughts at all? really need to try and fix this


Top
 Profile  
 
 Post subject: Re: avc-r not working
PostPosted: Wed Feb 14, 2024 8:13 am 
Offline
New Poster

Joined: Sat Nov 17, 2012 8:44 pm
Posts: 6
Location: S. Wales
Car Model: None
Hi,
this forum doesn't see much traffic these days, most people seem to favour social media!
Regarding the avcr, from memory, it was quite a rare beast even back in the day.
I just did a quick online search...
https://www.google.com/search?q=apexi+a ... s-wiz-serp
Have a read through some of the posts...most common issues, broken wiring loom, have you lchecked for loose/damaged cables, or soemthing about grounding/earth...both grounds must be used, and both must be good quality groundings, again, check both.
Hope this helps.

Darryl

_________________
eastgt4


Top
 Profile  
 
 Post subject: Re: avc-r not working
PostPosted: Tue Feb 27, 2024 4:44 pm 
Offline
Clubman

Joined: Mon Jan 04, 2010 9:07 pm
Posts: 65
Car Model: None
much apprecitated, know where your comeing from with regards to the use of socila media over forums
unfortunatly i dont use it so my options are limited

Ive also come to the conclussion after looking around that this is generally a (ground) issue
like you say at the loom end

dont think its a DIY for me, probably going to need it checked by a proper auto electrican to be sure


Top
 Profile  
 
 Post subject: Re: avc-r not working
PostPosted: Wed Feb 28, 2024 12:15 am 
Offline
Group B
User avatar

Joined: Sat Sep 02, 2006 3:13 pm
Posts: 3679
Location: Bournemouth
Car Model: None
I usually have a quick look on here every couple of weeks or so but, as above, very rare posts. Celica club UK is still a fairly active forum for quicker answers and much more likely to get a decent answer than on faceache.

Unfortunately I have no knowledge of the AVC-R. If you can post wiring diagrams from the handbook etc. I may be able to suggest more. Without that I can only suggest checking the 12V and the ground connections, i.e. make sure you have 12V on the wires going in to the unit. If it has 2 live feeds, e.g. permanent live for memory plus ignition live then check both are present. If it has power going in and no display then it's probably knackered.

_________________
If at first you don't suck seed, try drier grain.

Image


Top
 Profile  
 
 Post subject: Re: avc-r not working
PostPosted: Sun Mar 03, 2024 2:37 pm 
Offline
Clubman

Joined: Mon Jan 04, 2010 9:07 pm
Posts: 65
Car Model: None
yeah all posts ive read seem to lead to a ground issue at the Ecu end

as said probably best to get it checked by a auto electritian as im thinking
its probably going to need to be re-doing at the loom end

bit old school, but im leaning towards a dry joint that needs to be re-done
this type of thing is outside of my skill set as i dont really want to mess with the electrics


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group