www.gt4dc.co.uk
http://www.gt4dc.co.uk/forum/

ECU repair
http://www.gt4dc.co.uk/forum/viewtopic.php?f=2&t=5617
Page 1 of 4

Author:  Nibbles [ Wed May 16, 2012 8:32 pm ]
Post subject:  ECU repair

Since I've now seen the following failure on 2 ECU's (1st was a CS, 2nd an RC) I thought I'd post up the details so that others can consider repairing if they have a rare version.

The failure in both cases is a 10uF/50V capacitor which appears to be local decoupling on the flyback diodes for the idle solenoid. Not sure why it's failed, maybe just a slightly weak batch. It has also corroded away a track on the PCB which appears to be linking G- (dizzy trigger common) and a few other components to the main ground. I suspect this is what caused the symptoms.

Symptoms in the first case were intermittant cutting out / non start which would clear after a time.
Symptoms in the second case, for a few weeks the ECU light had been coming on & off at random but no stored codes. It then refused to start when warm, but once started (after several hours off) would keep running.

The failed component, with it's innards leaked out over the surrounding area.

Image

Step 1 - remove the component. Melt the legs with a soldering iron and pull out. Don't try sucking the solder first then pulling out cold. It's a plated through board and the legs tend to stay soldered in the middle so you then pull out the through plating when you pull the component.

Image

Step 2 - Clean the mess off the board using solvent & a stiff brush.

Image

Step 3 - Check continuity of all affected tracks and bridge and broken / suspect ones with wire.

Image

Step 4 - Clear the component holes with a solder sucker, then a quick squirt of protective laquer. (I use HPA as it's moisture repellant). I do this before fitting the new component as it would mask the spray from the area underneath.

Image

Step 5 - Refit the new component (10uF/50V), bridge another suspect track on the other side and another spray of laquer. on both sides.

Image

Author:  Diceman [ Wed May 16, 2012 9:51 pm ]
Post subject: 

hmm,
worthwhile carrying out some preventative maintenance by the looks of it. I wonder what temp it gets to inside the ECU case, unusual for a cap to fail like that at what probably amounts to 5000 hours ish?

Author:  Nibbles [ Thu May 17, 2012 11:24 am ]
Post subject: 

ight be worthwhile for a few more people to have a peek in their ECU's.
The symptoms we experienced are not consistent with failure of the capacitor itself and more likely failure of the surrounding track(s) once corroded, or possibly any conductivity of the goo expelled between tracks/components.
I suspect there may be several ecu's with the capacitor failed but not ahowing any symptoms as yet.

Author:  Nibbles [ Sun Jun 16, 2013 6:59 pm ]
Post subject:  Re: ECU repair

Just to update this thread, I've now seen 3 ecu's that have 'died' and been repaired - 2xCS and 1xRC. Plus I also looked at a spare RC ECU which had one capacitor leaking but hadn't actually 'failed' or even seen any symptoms.

Also, there is a capacitor of the same value on the small top board which has also failed on 2 of the above ECU's, and definaely causing the failure on one of them.

edit note - adding some pictures making clear which capacitors have been showing problems on each board.

https://www.dropbox.com/s/9yevt51ntu7ec ... 5.jpg?dl=0

https://www.dropbox.com/s/9pp06prj4u5wn ... 5.JPG?dl=0

Author:  niblettr [ Mon Jun 17, 2013 8:34 pm ]
Post subject:  Re: ECU repair

Add 2 st205 blitz ecus (the toyota pcb had the failed cap) to that list.

Author:  squarepants [ Wed Jun 19, 2013 9:55 pm ]
Post subject:  Re: ECU repair

Hi Nibbles,

Do you offer a repair? I know you kindly looked at Jeffs ecu for him and I potentially (from the symptoms described - hot start issue) have the same problem.

My ecu is a rev 1 Mines p&P

Would be good to know there's an avenue if needed.

Cheers

Author:  Nibbles [ Thu Jun 20, 2013 11:44 am ]
Post subject:  Re: ECU repair

I'm happy to have a look and sort out any leaking capacitors but I have no means of testing a rev 1.

Author:  squarepants [ Sun Jun 23, 2013 3:05 pm ]
Post subject:  Re: ECU repair

ok bud that's good to know.

I'll test it for you :D

Will be in touch if needs be

Author:  jeff [ Wed Jun 26, 2013 9:58 am ]
Post subject:  Re: ECU repair

I hope it is OK to link this post over to OC as Adam (woosh) is investigating similar problems :)

http://www.gt4oc.net/forums/viewtopic.p ... 2#p1402942

Author:  Nibbles [ Wed Jun 26, 2013 6:24 pm ]
Post subject:  Re: ECU repair

Post away, but I can't read it :( tell him to contact me if he wants. He can get my number off Phil.

Author:  jeff [ Wed Jun 26, 2013 6:35 pm ]
Post subject:  Re: ECU repair

Will do. Ta Chris.
Check out myitshot on OC? yellowhot now... and he has had 4 birthdays in the last week :) 2, 100, 69 and now 21... getting to be like the old days again.... so sad :) so sick 'shrug'

Author:  Nibbles [ Wed Jun 26, 2013 7:12 pm ]
Post subject:  Re: ECU repair

yellowhot ? I'm completely lost :lol:

Author:  NoGT4 [ Wed Jun 26, 2013 7:31 pm ]
Post subject:  Re: ECU repair

Chris............

myitshot of the OC has had a yellow card (warning) for some reason?

His user name has changed to yellowhot, and he keeps changing his birthday in his profile, so he pops up on "todays birthdays" on the forum
with different ages.

Jeff............

Chris is not on the OC.

Anyway, I think Woosh can sort his ECU, but if not, I am sure he will be in touch :D

Author:  Nibbles [ Wed Jun 26, 2013 7:43 pm ]
Post subject:  Re: ECU repair

so - mental age, real age, wishful thinking, shoe size :lol:

Author:  Woosh [ Wed Jun 26, 2013 7:46 pm ]
Post subject:  Re: ECU repair

Well i have been suffering from a miss fire of late that i could not clear i did the normal suspects HT leads,distributor cap,rotor arm,plugs,fuel filter and air filter which did not cure the problem. I then compression tested the engine fearing the worse but it was good compression 170 on three cylinders and 168 on number two.

So my attention turned to the ECU as i have heard of these failing i think it was Jeff that had issues with this recently. I managed to get a second hand unit from an RC and the car ran properly again which confirmed my thoughts so i opened up the original ecu up to find that it has two leaking capacitors which then lead me to open up the spare this also has a leaking capacitor.

I believe this is a problem that is going to become more of a issue in the future and even the St205 could suffer as they get older i will put up a detailed thread on how to repair these once i have done the job on mine but here is a few pictures and information for now.

Toyota Engine Control 89661 - 2B320
3S-GT 175000-4852 12V DENSO
Electrolytic Capacitors


175031-4820 Large PCB

C810 10µF 50v Faulty
C801 15µF 35v
C101 100µF 10v
C109 220µF 10v
C004 33µF 35v
C002 47µF 63v


U10924204B Small PCB

C512 10µF 50v Faulty
C500 100µF 10v


Ecu with the top remove and now i understand why it made good power a superchip has been fitted
Image
Image
Bottom of the ECU removed
Image
One of the offending capacitors
Image
The other offending capacitor
Image
The superchip
Image
Image

Thats my findings so far Nibbles both the ECU's i have are faulty with the same two capacitors leaking if you don't mind mate ill be in contact to have a chat

Page 1 of 4 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/